const regex = /((^| )sim( |$))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((^| )sim( |$))', '')
const str = `Talvez não sim`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);