using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((^| )sim( |$))";
string substitution = @"$2";
string input = @"Talvez não sim";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}