package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^(?:a|c|b[^c])+$)`)
var str = `abc
acb
ccbc
bac
bca
aaa
cab
cba
cabcabcbacbcaaaccbbaaccacbac`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}