import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(?:a|c|b[^c])+$)";
final String string = "abc\n\n"
+ "acb\n\n"
+ "ccbc\n\n"
+ "bac\n\n"
+ "bca\n\n"
+ "aaa\n\n"
+ "cab\n\n"
+ "cba\n\n"
+ "cabcabcbacbcaaaccbbaaccacbac";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}