import re
regex = re.compile(r"(^(?:a|c|b[^c])+$)", flags=re.MULTILINE)
test_str = ("abc\n\n"
"acb\n\n"
"ccbc\n\n"
"bac\n\n"
"bca\n\n"
"aaa\n\n"
"cab\n\n"
"cba\n\n"
"cabcabcbacbcaaaccbbaaccacbac")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")