using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?|(?<year>[0-9]{4})[-\/\\](?<month>[0-9]{2})|(?<month>[0-9]{2})[-\/\\](?<year>[0-9]{4}))";
string input = @"1996\09
1996-09
09-1996
09/1996
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}