package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?|(?<year>[0-9]{4})[-\/\\](?<month>[0-9]{2})|(?<month>[0-9]{2})[-\/\\](?<year>[0-9]{4}))`)
var str = `1996\09
1996-09
09-1996
09/1996
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}