$re = '/(?|(?<year>[0-9]{4})[-\/\\\\](?<month>[0-9]{2})|(?<month>[0-9]{2})[-\/\\\\](?<year>[0-9]{4}))/m';
$str = '1996\\09
1996-09
09-1996
09/1996
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);