# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\'\"])((?:.(?\1))*.?)\1//;t' <<< "Lorem ipsum \"'dolor sit amet consectetur'\" adipiscing \"elite\" ellentesque
scelerisque 'tortor' tortor in `vestibulum` dolor"