#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([\'\"])((?:.(?\1))*.?)\1"
Local $sString = "Lorem ipsum "'dolor sit amet consectetur'" adipiscing "elite" ellentesque " & @CRLF & _
"" & @CRLF & _
"scelerisque 'tortor' tortor in `vestibulum` dolor"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)