import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\'\\\"])((?:.(?\\1))*.?)\\1";
final String string = "Lorem ipsum \"'dolor sit amet consectetur'\" adipiscing \"elite\" ellentesque \n\n"
+ "scelerisque 'tortor' tortor in `vestibulum` dolor";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}