using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[P\].+?\[\/P\]";
string input = @"President [P] Barack Obama [/P] met Microsoft founder [P] Bill Gates [/P], yesterday.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}