$re = '/\[P\].+?\[\/P\]/';
$str = 'President [P] Barack Obama [/P] met Microsoft founder [P] Bill Gates [/P], yesterday.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);