re = /\[P\].+?\[\/P\]/
str = 'President [P] Barack Obama [/P] met Microsoft founder [P] Bill Gates [/P], yesterday.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end