const regex = /(\d{4}\.\dg).+(\d\d:\d\d:\d\d)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{4}\\.\\dg).+(\\d\\d:\\d\\d:\\d\\d)', '')
const str = `1967.0g 12:03:42`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}