$re = '/(\d{4}\.\dg).+(\d\d:\d\d:\d\d)/';
$str = '1967.0g 12:03:42';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);