using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^_\n]*)_([^_\n]*)(_.*)?";
string substitution = @"$2--$1$3";
string input = @"foo_bar_something-like_this-me
bar--foo_something-like_this-me
something-like--bar--foo_this-me
this-me--something-like--bar--foo
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}