use strict;
my $str = 'foo_bar_something-like_this-me
bar--foo_something-like_this-me
something-like--bar--foo_this-me
this-me--something-like--bar--foo
';
my $regex = qr/([^_\n]*)_([^_\n]*)(_.*)?/p;
my $subst = '$2--$1$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";