re = /([^_\n]*)_([^_\n]*)(_.*)?/
str = 'foo_bar_something-like_this-me
bar--foo_something-like_this-me
something-like--bar--foo_this-me
this-me--something-like--bar--foo
'
subst = '$2--$1$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result