using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<="") (?! )[^""\r\n]+(?="")";
string input = @"""Walk.""
"" Walk.""
"" Walk.""
""Don't Walk""
"" Don't Walk""
"" Don't Walk""
""Don't wait, get movin'""
"" Don't wait, get movin'""
"" Don't wait, Thelma, get movin'""
"" Don't wait, Thelma,
get movin'""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}