$re = '/(?<=") (?! )[^"\r\n]+(?=")/m';
$str = '"Walk."
" Walk."
" Walk.""
"Don\'t Walk"
" Don\'t Walk"
"" Don\'t Walk""
"Don\'t wait, get movin\'"
" Don\'t wait, get movin\'"
" Don\'t wait, Thelma, get movin\'"
" Don\'t wait, Thelma,
get movin\'"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);