#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<Number>[0-9]{9}\.?(?:[0-9]{2})?)$"
Local $sString = "I am trying to make a textbox in UWP only allow the following input: 9 digits, followed by a '.' (optional), followed by 2 digits (optional), by using Regex." & @CRLF & _
"" & @CRLF & _
"So far i have come up with an expression that allows 9 digits, or 9 digits and a '.'" & @CRLF & _
"" & @CRLF & _
"string pattern = @"^(?<Number>([0-9]{0,9})(\.?)([0-9]{0,2}?))"; " & @CRLF & _
"I want it to accept " & @CRLF & _
"123456789" & @CRLF & _
" or " & @CRLF & _
"123456789.12" & @CRLF & _
" as inputs." & @CRLF & _
"" & @CRLF & _
"But now it only accepts " & @CRLF & _
"123456789" & @CRLF & _
" or " & @CRLF & _
"123456789."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")