package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<Number>[0-9]{9}\.?(?:[0-9]{2})?)$`)
var str = `I am trying to make a textbox in UWP only allow the following input: 9 digits, followed by a '.' (optional), followed by 2 digits (optional), by using Regex.
So far i have come up with an expression that allows 9 digits, or 9 digits and a '.'
string pattern = @"^(?<Number>([0-9]{0,9})(\.?)([0-9]{0,2}?))";
I want it to accept
123456789
or
123456789.12
as inputs.
But now it only accepts
123456789
or
123456789.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}