use strict;
my $str = 'I am trying to make a textbox in UWP only allow the following input: 9 digits, followed by a \'.\' (optional), followed by 2 digits (optional), by using Regex.
So far i have come up with an expression that allows 9 digits, or 9 digits and a \'.\'
string pattern = @"^(?<Number>([0-9]{0,9})(\\.?)([0-9]{0,2}?))";
I want it to accept
123456789
or
123456789.12
as inputs.
But now it only accepts
123456789
or
123456789.';
my $regex = qr/^(?<Number>[0-9]{9}\.?(?:[0-9]{2})?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}