using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"rev(enue )?(op(eration)?s?)|g(?:o(?:-|\s)to(?:-|\s))?m(?:arket)?(?:\s*(?:ops|operations))?|sales\s*(ops|operations|analysts?|bi|intelligence|enablement|data|automation)|crm manager|business systems|(growth|market(ing)?)\s*(operations|ops)";
string input = @" ""Revenue Ops Manager"",
""Growth Marketing Manager"",
""CEO"",
""Director of Operations"",
""Sales Ops Analyst"",
""VP of Sales"",
""Marketing Operations Specialist"",
""Lead Generation Manager"",
""Product Ops Director"",
""GTM Strategy Lead"",
""Head of Growth"",
""Chief Marketing Officer"",
""Director of Business Development"",
""Junior Revenue Analyst"",
""Freelance Growth Consultant"",
""CTO and Product Owner"",
""Sales Development Representative"",
""Intern Marketing Operations"",
""Business Systems Administrator"",
""Country Manager and COO"",
""Chief Growth Officer"",
""VP Marketing and Communications"",
""Head of Business Opportunities"",
""Revenue Operations Specialist"",
""Product Marketing Manager""
Revenue Ops
RevOps
Chief Revenue Officer
CRO
CMO";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}