// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)rev(enue )?(op(eration)?s?)|g(?:o(?:-|\s)to(?:-|\s))?m(?:arket)?(?:\s*(?:ops|operations))?|sales\s*(ops|operations|analysts?|bi|intelligence|enablement|data|automation)|crm manager|business systems|(growth|market(ing)?)\s*(operations|ops)").unwrap();
let string = " \"Revenue Ops Manager\",
\"Growth Marketing Manager\",
\"CEO\",
\"Director of Operations\",
\"Sales Ops Analyst\",
\"VP of Sales\",
\"Marketing Operations Specialist\",
\"Lead Generation Manager\",
\"Product Ops Director\",
\"GTM Strategy Lead\",
\"Head of Growth\",
\"Chief Marketing Officer\",
\"Director of Business Development\",
\"Junior Revenue Analyst\",
\"Freelance Growth Consultant\",
\"CTO and Product Owner\",
\"Sales Development Representative\",
\"Intern Marketing Operations\",
\"Business Systems Administrator\",
\"Country Manager and COO\",
\"Chief Growth Officer\",
\"VP Marketing and Communications\",
\"Head of Business Opportunities\",
\"Revenue Operations Specialist\",
\"Product Marketing Manager\"
Revenue Ops
RevOps
Chief Revenue Officer
CRO
CMO";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}