# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"rev(enue )?(op(eration)?s?)|g(?:o(?:-|\s)to(?:-|\s))?m(?:arket)?(?:\s*(?:ops|operations))?|sales\s*(ops|operations|analysts?|bi|intelligence|enablement|data|automation)|crm manager|business systems|(growth|market(ing)?)\s*(operations|ops)"
test_str = (" \"Revenue Ops Manager\",\n"
" \"Growth Marketing Manager\",\n"
" \"CEO\",\n"
" \"Director of Operations\",\n"
" \"Sales Ops Analyst\",\n"
" \"VP of Sales\",\n"
" \"Marketing Operations Specialist\",\n"
" \"Lead Generation Manager\",\n"
" \"Product Ops Director\",\n"
" \"GTM Strategy Lead\",\n"
" \"Head of Growth\",\n"
" \"Chief Marketing Officer\",\n"
" \"Director of Business Development\",\n"
" \"Junior Revenue Analyst\",\n"
" \"Freelance Growth Consultant\",\n"
" \"CTO and Product Owner\",\n"
" \"Sales Development Representative\",\n"
" \"Intern Marketing Operations\",\n"
" \"Business Systems Administrator\",\n"
" \"Country Manager and COO\",\n"
" \"Chief Growth Officer\",\n"
" \"VP Marketing and Communications\",\n"
" \"Head of Business Opportunities\",\n"
" \"Revenue Operations Specialist\",\n"
" \"Product Marketing Manager\"\n"
"Revenue Ops\n"
"RevOps\n"
"Chief Revenue Officer\n"
"CRO\n"
"CMO")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.