#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\bnumbers\b|(?!^)\G).*?\b(\d{3})\b"
Local $sString = "The numbers are 144, 424, and 345. Not 45." & @CRLF & _
"The numbers we are looking for: 234 & 992" & @CRLF & _
"Some examples: 234, 244 and 12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")