const regex = /(\bnumbers\b|(?!^)\G).*?\b(\d{3})\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\bnumbers\\b|(?!^)\\G).*?\\b(\\d{3})\\b', 'gm')
const str = `The numbers are 144, 424, and 345. Not 45.
The numbers we are looking for: 234 & 992
Some examples: 234, 244 and 12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}