$re = '/(\bnumbers\b|(?!^)\G).*?\b(\d{3})\b/m';
$str = 'The numbers are 144, 424, and 345. Not 45.
The numbers we are looking for: 234 & 992
Some examples: 234, 244 and 12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);