const regex = /\b\d{16}\b|\b(\d{4})\s+\1\s+\1\s+\1\b/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{16}\\b|\\b(\\d{4})\\s+\\1\\s+\\1\\s+\\1\\b', '')
const str = `test 1234123412341234 kzugzughl`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}