re = /\b\d{16}\b|\b(\d{4})\s+\1\s+\1\s+\1\b/
str = 'test 1234123412341234 kzugzughl'
# Print the match result
str.match(re) do |match|
puts match.to_s
end