$re = '/\b\d{16}\b|\b(\d{4})\s+\1\s+\1\s+\1\b/';
$str = 'test 1234123412341234 kzugzughl';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);