const regex = /(\d+(\.\d+)?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+(\\.\\d+)?)', 'g')
const str = `'Discount 7.5%' should get 7.5
'Discount 15%' should get 15
'Discount 10%' should get 10
'Discount 5%' should get 5`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);