re = /(\d+(\.\d+)?)/
str = '\'Discount 7.5%\' should get 7.5
\'Discount 15%\' should get 15
\'Discount 10%\' should get 10
\'Discount 5%\' should get 5'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result