using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:(?=^\S{8,}$)(?:(?=\S*\d)(?=\S*[A-Z])(?=\S*[a-z])|(?=\S*\d)(?=\S*[^A-Za-z0-9])(?=\S*[a-z])|(?=\S*[^A-Za-z0-9])(?=\S*[A-Z])(?=\S*[a-z])|(?=\S*\d)(?=\S*[A-Z])(?=\S*[^A-Za-z0-9]))^\S*){8,})";
string input = @"aaaaa8A?";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}