import re
regex = re.compile(r"((?:(?=^\S{8,}$)(?:(?=\S*\d)(?=\S*[A-Z])(?=\S*[a-z])|(?=\S*\d)(?=\S*[^A-Za-z0-9])(?=\S*[a-z])|(?=\S*[^A-Za-z0-9])(?=\S*[A-Z])(?=\S*[a-z])|(?=\S*\d)(?=\S*[A-Z])(?=\S*[^A-Za-z0-9]))^\S*){8,})")
test_str = "aaaaa8A?"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")