using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ЩербакоÐ0а ТатьÑ�на ВиктороÐ0на";
string input = @"ЩербакоÐ0а ТатьÑ�на ВиктороÐ0на";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}