const regex = /.+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+', 'gm')
const str = `在 V2EX 的人 个个是人才,说话又好听,超喜欢在 V2EX 这里玩。 - by V2EX 2020 年 5 月 10 日`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}