re = /.+/m
str = '在 V2EX 的人 个个是人才,说话又好听,超喜欢在 V2EX 这里玩。 - by V2EX 2020 年 5 月 10 日'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end