const regex = /^(.+?)(?:(?:@example1\.com)?|(?=@))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.+?)(?:(?:@example1\\.com)?|(?=@))$', 'gm')
const str = `test@example1.com
test@example2.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}