$re = '/^(.+?)(?:(?:@example1\.com)?|(?=@))$/m';
$str = 'test@example1.com
test@example2.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);