package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\[NOTE]][^[\]]+\[\[NOTE]]`)
var str = `[[NOTE]]This is my note.[[NOTE]]`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}