// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[\[NOTE]][^[\]]+\[\[NOTE]]").unwrap();
let string = "[[NOTE]]This is my note.[[NOTE]]";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}