re = /\[\[NOTE]][^[\]]+\[\[NOTE]]/m
str = '[[NOTE]]This is my note.[[NOTE]]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result