import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "value='(?:[^,]+,){2}([^,]+),([^,]+)'>[^-]+-\\s+([^(]+)(?=\\s)";
final String string = "value='C,201301,F110,JEWL1050'>JEWL1050 - Industry Skills I (F110)</option>\n"
+ "value='C,201301,F114,JEWL1050'>JEWL1050 - Industry Skills I (F114)</option>\n"
+ "value='C,201301,F114,JEWL1054'>JEWL1054 - Jewellery Rendering & Illustra (F114)</option>\n"
+ "value='C,201301,F110,JEWL2029'>JEWL2029 - Production Techniques B (F110)</option>\n"
+ "value='C,201301,F114,JEWL2029'>JEWL2029 - Production Techniques B (F114)</option>\n"
+ "value='C,201301,LIAD,LANG9066'>LANG9066 - Italian For Beginners (LIAD)</option>\n"
+ "value='C,201301,T302,LAW1151'>LAW1151 - Canandian & Environmental Law (T302)</option>\n"
+ "value='C,201301,T305,LAW1151'>LAW1151 - Canandian & Environmental Law (T305)</option>\n"
+ "value='C,201301,F402,LAW1152'>LAW1152 - International Law & Agreements (F402)</option>\n"
+ "value='C,201301,T302,LAW3201'>LAW3201 - Protection Legislation (T302)</option>\n"
+ "value='C,201301,T303,LAW3201'>LAW3201 - Protection Legislation (T303)</option>\n"
+ "value='C,201301,T304,LAW3201'>LAW3201 - Protection Legislation (T304)</option>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}