# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"value='(?:[^,]+,){2}([^,]+),([^,]+)'>[^-]+-\s+([^(]+)(?=\s)"
test_str = ("value='C,201301,F110,JEWL1050'>JEWL1050 - Industry Skills I (F110)</option>\n"
"value='C,201301,F114,JEWL1050'>JEWL1050 - Industry Skills I (F114)</option>\n"
"value='C,201301,F114,JEWL1054'>JEWL1054 - Jewellery Rendering & Illustra (F114)</option>\n"
"value='C,201301,F110,JEWL2029'>JEWL2029 - Production Techniques B (F110)</option>\n"
"value='C,201301,F114,JEWL2029'>JEWL2029 - Production Techniques B (F114)</option>\n"
"value='C,201301,LIAD,LANG9066'>LANG9066 - Italian For Beginners (LIAD)</option>\n"
"value='C,201301,T302,LAW1151'>LAW1151 - Canandian & Environmental Law (T302)</option>\n"
"value='C,201301,T305,LAW1151'>LAW1151 - Canandian & Environmental Law (T305)</option>\n"
"value='C,201301,F402,LAW1152'>LAW1152 - International Law & Agreements (F402)</option>\n"
"value='C,201301,T302,LAW3201'>LAW3201 - Protection Legislation (T302)</option>\n"
"value='C,201301,T303,LAW3201'>LAW3201 - Protection Legislation (T303)</option>\n"
"value='C,201301,T304,LAW3201'>LAW3201 - Protection Legislation (T304)</option>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.