re = /value='(?:[^,]+,){2}([^,]+),([^,]+)'>[^-]+-\s+([^(]+)(?=\s)/
str = 'value=\'C,201301,F110,JEWL1050\'>JEWL1050 - Industry Skills I (F110)</option>
value=\'C,201301,F114,JEWL1050\'>JEWL1050 - Industry Skills I (F114)</option>
value=\'C,201301,F114,JEWL1054\'>JEWL1054 - Jewellery Rendering & Illustra (F114)</option>
value=\'C,201301,F110,JEWL2029\'>JEWL2029 - Production Techniques B (F110)</option>
value=\'C,201301,F114,JEWL2029\'>JEWL2029 - Production Techniques B (F114)</option>
value=\'C,201301,LIAD,LANG9066\'>LANG9066 - Italian For Beginners (LIAD)</option>
value=\'C,201301,T302,LAW1151\'>LAW1151 - Canandian & Environmental Law (T302)</option>
value=\'C,201301,T305,LAW1151\'>LAW1151 - Canandian & Environmental Law (T305)</option>
value=\'C,201301,F402,LAW1152\'>LAW1152 - International Law & Agreements (F402)</option>
value=\'C,201301,T302,LAW3201\'>LAW3201 - Protection Legislation (T302)</option>
value=\'C,201301,T303,LAW3201\'>LAW3201 - Protection Legislation (T303)</option>
value=\'C,201301,T304,LAW3201\'>LAW3201 - Protection Legislation (T304)</option>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end