$re = '/(?<={).*(?=})/m';
$str = 'C:\\ADBackup\\GPOs{7AF2FC2F-7A88-47BB-9F61-BEE0C929DF6E}\\User\\Preferences\\Drives\\Drives.xml';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);