re = /(?<={).*(?=})/m
str = 'C:\\ADBackup\\GPOs{7AF2FC2F-7A88-47BB-9F61-BEE0C929DF6E}\\User\\Preferences\\Drives\\Drives.xml'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end